Delegation lost after evm update

I was delegating a significant amount to the Miami validator. Every week or two I would go in take my rewards from delegating and redelegate them. After the update all my funds appear to be gone. Does anyone know what happened to them or where they are? In the app it says I’m not delegating any…

Look under Delegate FX Classic.

For users who have not upgrade their address, your FX will be under “Delegate FX Classic” on f(x)Core Classic network.

For users who upgraded their classic to the new 0x address, it will be under “Delegate FX”.

It is recommended to upgrade because you will be able to interact with dApps and EVM blockchains or wallets like MetaMask.

Original fx address and the new 0x address difference:

1 Like

It says I’ve updated all my Addresses but my delegation isn’t showing it either fx classic or fx both show I have zero delegated

1 Like

First, don’t worry.
Nothing can be lost unless you lost your seedphrase.
Go on the first tab, and under f(x)core, click the “…” And make sure you add all your addresses.
Then, you need to check your delegations using the 3rd tab, under “delegate f(x)”.



If you can’t find your FX under the first address, it may be that your FX coins are under another address, as @FrenchXCore said.

Your tokens are not lost, do not worry.

  1. Tap on f(x)Core Classic / f(x)Core Header
  2. Select “Switch & Add Address”
  3. Select the address your FX is in

After adding, check back under “Delegate FX” or “Delegate FX Classic” if you have not upgraded.

1 Like

I just tried that. All the address’s under both show a zero FX balance. I know my wallet is loaded correctly because I still show a small ETh balance that I had in there. That’s still there. But all my FX is gone

Actually thanks! I did just solve it… the switch account worked. There was one address with coins in it actually I scrolled down thru like 15 with a zero balance. Not sure why there were so many in there but I did find it and really appreciate the help! Thanks


No worries, this is a common case because in the first version of f(x)Wallet, users had multiple addresses stored on each network, and after the upgrade to f(x)Wallet 2.0, some users forgot which address they used.

So usually, their coins are actually stored in one of the addresses in the list under “Switch & Add Address” and they just need to re-add it again.

Cheers :wine_glass:

1 Like