Error trying to Unjail Validator due to down time

I received the error msg as shown above… can i know how to i self-delegate again?

Thanks in advance

@piggyinu ,

Since your validator was jailed, it is very likely your self-bonded delegation went below the minimum required which is 100 FX.
You need first have more than 100 FX self-bonded, and then you’ll be able to unjail again.
Please let us know what your Telegram @ID is along with the name of your validator please.


Hi… how do i top up the 100 fx again?

  1. First, you need to send the missing FX (to reach at least 100 F$X, or let’s say 110 $FX if you don’t want that to happen again) to your validator self-bonded address : something like “fx1…”
    The example below is if you validator address is fxvaloper1a8prwglrf4ka0k9kcadu725pmttleujn8dgu5w : you’ll then need to transfer 10.1 $FX to the validator self-bonded address fx1a8prwglrf4ka0k9kcadu725pmttleujn0u4r2w
  2. You then need to delegate (self-bond delegation) to your own validator :
    fxcored tx staking delegate fxvaloper1a8prwglrf4ka0k9kcadu725pmttleujn8dgu5w 10100000000000000000FX --gas="auto" --gas-adjustment=1.2 --gas-prices="4000000000000FX" --from="kittynet"
    Replace the fxvaloper1… address with your validator address.
  3. Then you can unjail using:
    fxcored tx slashing unjail --from="kittynet" --gas="auto" --gas-adjustment=1.2 --gas-prices="6000000000000FX"



Hi, I tried to query the validator info but got the error " desc = validator fxvaloper1z7y9nzq36gmayl0k46nsmdtz0psuw5ztmnc0e2 not found: key not found"

what am i doing wrong here? Thanks again!

I can’t find a trace of this FX validator address : fxvaloper1z7y9nzq36gmayl0k46nsmdtz0psuw5ztmnc0e2
However, I could find 100 $FX available on fx1z7y9nzq36gmayl0k46nsmdtz0psuw5ztnz9s82 FX address.

Did you keep a copy of the response when your did use the create_validator command please ?
I wouldn’t be surprised if you did erase your previous validator info when reinstalling the latest version.


Hi, I did erase the previous validator info and created a new validator as screen shot above.

this is the output when i tried to test for active validator

This validator was not created yet : fxvaloper1z7y9nzq36gmayl0k46nsmdtz0psuw5ztmnc0e2
And you cannot unjail a non-existing validator.

fxcored tx staking create-validator
–pubkey=$(fxcored tendermint show-validator)
–details=“To infinity and beyond!”

I thought i created the validator using the above command. Is there additional command i need to type?

First, please replace this row --moniker="your-moniker" with a more convenient name for your validator, such as --moniker="piggyinu".
When checking your FX address on the Testnet Explorer, you should see your create_validator transaction result.
Then, you need to show me the output of this command.

I see that a validator was created using this FX address 2 hours ago : fx1ld8qr9n0pyllxdek87p3sra6yfqxs4r0snpqnf. Isn’t that one of yours ?

Yes it is mine for kittynet1. isnt my creation of validator successful or i need to create again changing the --moniker parameters?

I tried to change the moniker using the edit-validator command.

Hi, how to I find out fxvaloper1ld8qr9n0pyllxdek87p3sra6yfqxs4r0czuldf is my validator address using the cli commands?