f(x)Core Mainnet Validator Bugs/Fixes & Technical Support

Thx for the analytics. @FrenchXCore. For all the validators who have yet to set up their node monitoring device, please do so. More on how to setup

Once you have set up, you can create an alert bot on telegram to notify you of any issues with your validator node.


some of you were asking about changing comms rate and raised the issue that the comms rate didnt change even after editing it. you may refer to this part of the document for more information on that.

  • Initial commission rate : The commission rate on block rewards and fees that will be charged by validators and charged to delegators (more information can be found below).

  • Maximum commission: The maximum commission rate which this validator can charge. This parameter cannot be changed after create-validator is processed.

  • Commission max change rate: The maximum daily increase of the validator commission. This parameter cannot be changed after create-validator is processed.

if you have already raised the comms rate within 24hours, you wouldnt be able to do so again within 24hrs.


Morning Richard.

So I’ve entered this;

fxcored tx staking edit-validator --moniker=“Superbit123” --website=“https://twitter.com/Superbit123 " --identity=”" --details=“One for All, All for One :muscle:” --commission-rate=“0.03” --chain-id=fxcore --gas=“auto” --gas-adjustment=1.2 --gas-prices=“6000000000000FX” --from=superbit

Again it has successfully worked in the command end, but won’t actually change the actual output. A bit strange, could be a bug.

I am aware of the 24hr cool down period and max change rate.

Here is what FX Explorer says.
Notice the gas wanted, circled.

Tx hash;
0xadc32fa913919e121c6018c4b7a22f07cca82b93bc430da7b2ca760add55d2a3 )

The gas/used wanted does change in what it requires from time to time. I’ve never hit the 100% here with this commission set out.

Other validators have responded with the same cli coding I’ve used above to be okay.

On few attempts I’ve even tried to changed the

gas-adjustment=2.0 --gas-prices="12000000000000FX. Again the command works, but nothing in the end result changes.

Update; so I’ve tried to tweek the gas a bit, to see if I can fill the required gas wanted;

fxcored tx staking edit-validator --moniker=“Superbit123” --website=“https://twitter.com/Superbit123 " --identity=”" --details=“One for All, All for One :muscle:” --commission-rate=“0.03” --chain-id=fxcore --gas=“auto” --gas-adjustment=1.3 --gas-prices=“7000000000000FX” --from=superbit

Atm it is guess work for me and I’ve not yet fulfilled the 100% gas wanted. Perhaps then it will change the coms.

The last attempt was much close at 99.2%.

Any suggestions what I can try out?

@Superbit123 : you can use the fxcored tx simulate command to check ho much gas is required for your transaction…
But I don’t understand what you’re trying to reach…
Right now, all vidators (or most of them) are setup with 40000…000 FX for gas Price. No need to increase that.

Hi everyone,

I’m trying to setup a validator and join your community. Have some technical background, but not much in the scope of blockchain technology.

Anyhow, while going through the setup guide I ran into the following issue:
After downloading today’s snapshot and extracting it, I proceeded as per the guide to start the node. It showed the following message:

checking on status throws this:
fxcored status
Error: post failed: Post “http://localhost:26657”: dial tcp [::1]:26657: connect: connection refused

1 Like

@FrenchXCore @kenorb @indra

Hi Janc,

First and foremost, welcome to the fx community!

Which snapshot did you download, and which version of fxcore are you running?

thanks for the welcome!

used snap:
wget -c https://fx-mainnet.s3.amazonaws.com/fxcore-snapshot-mainnet-2022-09-19.tar.gz

root@functionX-Validator:~# fxcored version

Ubuntu 22.04

root@functionX-Validator:~# go version
go version go1.18.5 linux/amd64

1 Like

Ok, next thing I’d like to check, did you successfully extracted the snapshot before starting the node?

Hi !

I think the issue is that you need to download the full snapshot and “release/v1.1.x” to start with.
Because when you start fxcored, it’ll check each block one after another…
Once it’ll reach block 5713000 (or sthg like that), you’ll need to stop your fxcored process, upgrade to release/v2.2.x and then restart fxcored process…

Otherwise, you can download the pruned snapshot and start from release/v2.2.x.


yes I used:
tar -xzvf fxcore-snapshot-mainnet-2022-09-19.tar.gz -C ~/.fxcore/

I left the console as I had some errands to run while the extracting was running. I downloaded and extracted the snapshot tar.gz into the fx-core directory created in the previous step setting up the fx core. not sure if that was correct?

root@functionX-Validator:~# ls -l ~/.fxcore/data/
total 480
drwxr-xr-x 2 root root 4096 Sep 20 05:42 blockstore.db
-rw------- 1 root root 46 Sep 19 12:58 priv_validator_state.json
drwx------ 2 root root 483328 Sep 19 13:38 state.db

1 Like

ah ok. I’ll try again with the pruned, thanks

update: the pruned worked

fxcored status now throws the expected output with last synced block. I’ll wait some hours now to give it time to sync up.

is there something I should do for the previous blocks that were not included in the pruned snap?

You only need the previous blocks if you need full history of the blockchain for queries.
Otherwise, the pruned one is fine…

HI guys, another problem:

after creating the validator with “fxcored tx staking create-validator” I receive the following output:

confirm transaction before signing and broadcasting [y/N]: y
code: 0
codespace: “”
data: “”
events: []
gas_used: “0”
gas_wanted: “0”
height: “0”
info: “”
logs: []
raw_log: ‘[]’
timestamp: “”
tx: null
txhash: 481E0F4DFD87F5A7D0DE3AA76E82608323E434A58A22382070BF983E92DB6621

running fxcored query tendermint-validator-set | grep “$(fxcored tendermint show-address)”
doesn’t return anything.

the 100fx for creating were taken from the validator wallet. I was also able to get the validators pubkey

1 Like

Your validator was created just fine : tx link
However, your moniker name seems weird : “amFuYw==”
Here are your addresses :

  • validator address : fxvaloper1mc84eaz33l77ue6s53c482lu6fvq5uexmyea8h
  • delegator self-bounded address : fx1mc84eaz33l77ue6s53c482lu6fvq5uexn4yzeh


  1. DO NOT upgrade your delegator/validator addresses to 0x EVM format.
  2. Try to get as much delegations as possible by contributing to the ecosystem, in order to enter the active 50-validators set. In the future, this number might increase (depends on governance).


I’ve tried adjusting commission rate by 0.01 (max change per day - I’m aware), and moniker:

raw_log: ‘insufficient fees; got: required: 320000000000000000FX: insufficient fee’

is that right? the validator wallet holds 100 fx

You need to specify fees switches:
--gas auto --gas-adjustment=1.3 --gas-prices="4000000000000FX" at the end of your CLI command.

my validator shows ‘inactive’ on starscan

how to get it active? everything seems to run fine

it also shows I missed all blocks, but fxcored status shows me catching_up: false and double checking latest block height confirms all is synced

1 Like

Hi @Janc !

You need to have more staked FX than the 50th active validator to enter automatically in the must.
Currently, the 50th is Kigali with 236 FX. You need 100 more FX to enter automatically in the active list.