f(x)Wallet -> Android and iOS app BUG (ETH address didn’t recover after f(X)Wallet was reinstalled)

I have had f(x)wallet installed and workiong for more than 3 months now. Selected it to stake Pundix. I wasn’t able to do it (but that’s a minor problem). This morning, f(x)wallet will not open. So I had to uninstall and then reinstall, use my recovery phrase to recover it. It is recovered but all my SHIB and Pundix coins are lost. Has this happened to anyone else and is there help to sort this out?

Add contract address of the tokens in add new token section

1 Like

Yes, it happened to me also after updating the app. All my unclaimed fx staking rewards from staking pundix were lost.

Hope someone from dev will help to recover my hard earned fx token.

Yes, it happened to me also after updating the app. All my unclaimed fx staking rewards from staking pundix were lost.

Hope someone from dev will help to recover my hard earned fx token.

Here’s attached the screen shot !

they are there! just uninstall app shut down reboot device and reload app do another reboot and restore the Wallet. team put up other fix methods in the forum, Make sure you have your seed before doing anything,

1 Like

Thank you for the advice. I will follow the steps to uninstall;reboot;reinstall, reboot and then revover the account. I hope in hope they are not lost. I was baffled that my o.019 ETH did not get lost, but the big amounts of PundiX and SHIB got lost.

How did this work out? I have staking rewards disappeared but all else is there. Got a fair few bob in the wallet so nervous about rebooting, un installing etc etc…

I have tried the uninstall / reboot / reinstall and it gave me the Uinstall / Update options. I chose Update and then use recovery phrase. Still the same result. So I will try again. I sent 3 messages to Function X support@functionx.zendesk.com and they responded that their support staff are working on it. It’s more than 24 hours since, but there is hope so I wait.

Just to add, I spoke to someone. Seems a bug with the new update, I understand they are trying to sort it. I actually loaded my wallet onto an iphone I had, have all functionality back without issue. Although understand not all have that luxury.

I had similar issue with f(x)wallet.
Turned out I had an old version on f(x)wallet on phone.
Resolved issue by goin to https://functionx.io/
Downloaded latest version of the wallet using direct link (didnt use app store).
When installing the .apk file, the old version of f(x)wallet was updated. It wasn’t a full re-install… didn’t have to enter seed or anything like that.

1 Like

Colleagues, I did Bob_X advice and thanks for that. I have an old IPHONE 6S, never had f(x)wallet installed there. Installed f(x)wallet fresh, and used recovery phrase to login. Same result as before. I am beginning to think Pundix and f(x)wallet are unsafe. It’s quite big for me, and with the feedback from you all, there would be many others. And Pundix and f(x) have only acknowledged my first email and nothing else. I appreciate all the advice and help from everyone else.

Same all my unclaimed fx staking rewards from staking pundix were lost.

They are not lost…

This bug is well known and described in this forum just do some reading on the now dozens of other similar posts.

There is a reset and reinstall process that will restore things back to normal if you wish to follow it. Otherwise wait for a update from the devs.

Questions: if it’s a known bug, why hasn’t Pundix and f(x)wallet put an official statement out? And why aren’t they responding to queries like mine? They have very poor customer services.

They have info on the web site and here and telegram, thanks

today a new update has launched, install it and that should fix the staking issues

Colleagues, I thank all of you and the Function X team. Finally, I have recovered all my PundiX and SHIB coins. Your posts and support from Function X team kept me hopeful. Such a beautiful sight to see all restored to my f(x)wallet. I believe in PundiX and f(x)wallet much stronger now. In short, after following steps to delete data and cache, then reinstall app, import account using recovery phrase, only ETH coins registered. But when I selected PundiX, then I saw the number of coins wasn’t zero, clicked on it and all were fully recovered. For SHIB, I had to add it and then did the same process.


I still have the same problem. Even after i uninstalled the wallet and reinstalled via the direct download link and after an update still no pundix or my unclaimed fx rewards.