f(x)Wallet -> Android app BUG (Wrong error when staking) || Patched

Hello, I’ve had this issue for a couple of months now but didn’t think much of it. Thought it’d probably get fixed and since my staking reward was low it wasn’t an issue. But now I want to stake more PundiX and the issue is the same.

I’ve tried reinstalling the app, resetting the wallet, changing phone language etc. This error about incorrectly formatted wallet appears.

How do I solve it? Cheers

Seems to be a bug, I will ask our dev team to look into it.

That regex in the error code would match any integer, so maybe try 310 without the decimals and let me know if it works.

Thanks for the reply, but to me it looks like it’s the wallet address it’s complaining about, doesn’t it? 0x… etc
I tried 310 like you said just in case, but no.
Also, I just discovered another issue. I was about to create a new wallet address to see if it would work, but I can’t - as soon as I select PundiX in my wallet and then click Add Address, the app crashes.

This is a Samsung Galaxy S20 btw.

PS. Wasn’t there some cutoff date now in June for claiming the 5% staking reward? Maybe I misread that, but I need to somehow either have this fixed before then or get help to claim… cause rn I’m stuck in either direction.

One more thing, no matter how hard I try to completely delete and reset the app - every time I reinstall it, it automatically opens my wallet. Even using the “reset my wallet” inside the app and then reinstalling… I automatically get into my old wallet again without entering the recovery phrase.

Is there a way to know what files to delete to properly reset this?

With the risk of becoming spammy - I now managed to factory reset my phone and restore the wallet with the recovery phrase. But the exact same issue persists…“Value must be in format…”
I was however able to create a new wallet address but trying to send the PundiX gives the exact same error message as above.

So I’m officially completely stuck :frowning:

Edit: I just tried with my old factory reset Galaxy S9 too. App has never been installed there and it’s an older android version etc. Same issue…

Have you some ETH for Fee?
The Error
look like you not have eth for gas

I think you’re actually right, at first I thought 0x was some sort of a different code but if it’s part of the regex then it wouldn’t match your address which starts with 0xD.

I’ve asked our dev team to look into it as well.

May I ask what language your phone is configured with in your phone settings, as well as the Android version you’re on right now?

Well, apparently it was because I didn’t have ETH for the fees. I got told this by the support over e-mail.
But that’s one really strange error message. Must still be a bug imo. The fact that it doesn’t state that I don’t have ETH or tell me how much I need to transfer over, but rather makes some generic error about my wallet ID… So now I had to transfer over way more ETH than was required not to risk getting double fees because I didn’t have enough.

I know a new app is on the horizon and I really hope these issues gets ironed out.

Thanks for taking your time!

Well, it’s good that we found a go-around for this until it’s fixed. The dev team now has access to this thread as well and I’ll send an update soon about when this bug will be patched.

A post was split to a new topic: Different address in the “send to” variable when claiming