f(x)Wallet -> iOS app BUG (Transaction notification when there's no transaction)

Phone OS (Android or iOS - Apple): Apple ipad
Phone language: english
Phone resolution:

When i open the wallet i see that a transaction keeps running without any real transaction takes place. Did I do something wrong? How can I solve this.

1 Like

@indra any suggestions?

Had similar issue due to Ethereum network - specifically is “Dropped & Replaced Transaction” - happens more frequently during times when the Ethereum network is busy.


I’ve informed team on this, and dev team is looking into “Clearing The Nonce” on future updates.

In summary, this feature is required inside FX Wallet to overwrite the previously stuck transaction.

A transaction can get dropped and replaced when a newly created transaction with the same FROM account nonce is accepted and confirmed by the network. And because it has the same account nonce as the previous transaction, it replaces the previous txhash.

I believe the amount of FX tokens are still intact under your account, so let’s wait for the team to resolve this.

1 Like

Tried the conversion again today, and it’s working now.

The issue is Ethereum network, not FX(Core) issue.

If you’re having similar issue, wait a couple of days and try again (when Ethereum network is not so busy).

I think I might hold the record! Is there a way of dealing with this to clear it?

You think?

I had one that I did a second TX to by pass the one not being excepted and the one still not processed doing the above, I uninstalled the wallet and reloaded the app and the TX disappeared, Please make sure you have your seed before doing that