PURSE staking issue

I’ve connected my fxwallet purse bcs adres to the staking page on pursetoken.com.
Used Chrome app and option walletconnect.

Approved to allow spending of purse token.
Tx hash:

Clicked “stake” in the stake tab. Clicked on max and stake.

But seems to be stuck then.
Wheel keeps spinning for couple of hours.

Disconnected and then reconnected again.
Only see the “approve” option.
So try to approve again, but get stuck.
Again wheel keeps spinning…

I have about $20 BNB in wallet. Should be enough?

Do i miss something or doing something not right?

Hi bro :wave: on pc right ? i used chrome desktop and worked fine.
also worked fine with trustwallet and safepal

Mine worked fine using F(X)Wallet on Brave Browser.

Used the Chrome app on ipad.
Maybe thats the problem.
Will try desktop later on…must have an old laptop somewhere on the attic…:smile:

Though first step (approval) went ok on rhe ipad.

btw: also tried with Opera app on ipad, same issue.

Mine worked fine.

Yeah. Works now.
Switched devices too much apparently, during the different steps…
New attempt on good all iphone succesfull.

Sorry for the bother.

1 Like



why token balance’s not appeared on website, desktop chrome.