Unable to withdraw liquidity from FX-PundiX pair


I am unabe to withdraw liquidity from FX-PundiX pair. It allowed me to select how much liquidity i want to withdraw and successfully went through the approve process. But when i click the remove button, computer screen shows popup window to confirm the transaction on the wallet, but no transaction window shows up on the FX-wallet.

I have tried to disconnect and re-connect many times, still the same issue.

-Accessing FX Swap on Windows 10 Chrome
-FX wallet 2.2 installed on Samsung A5 Android
-Connected through wallet connect, tokens on FX Core

PS: fx wallet has bunch of cross chain and liquidity transactions i did over the past days showing pending (wheel spinning) even though all those transactions have been successfull. Some transactions are shwoing pending over 70 hours. Not sure if this is related to the issue i am facing.

I have the same issues while using WalletConnect.
Doesn’t work at all using Brave browser, and very capricious over Chrome browser. But usually, it gets thru over Chrome if you disconnect over Chrome, then close Chrome on desktop, disconnect FxWallet, and start again.
Probably a cache issue.