FX-Swap problem

FX-Swap has worked only one time for me. Im unable to do swaps. Problem occurs when i connect my f(x)wallet to fx-swap and try to do swaps. I dont get the confirmation option to my f(x)wallet. FX-Swap throws me to my wallet and nothing happens.

Second problem is that i changed my fxcore address to EVM compatible address and still f(x)wallet asks me to upgrade my fxcore classic address. It shows me the old classic address and new address. The new address is the same what i have already in my EVM compatible fxcore wallet.

I use android and my wallet is created in the early days when (fx)wallet was published. I changed my AVG virus protection to Avira and i have restarted my wallet with recovery phrase to other android phone but nothing changed. Where is the problem? FX-Swap has worked only one time.

  1. Try to clear the cache on your browser. See if it works.

  2. Did you upgrade your address? Once you upgrade, there is no option to upgrade. If it asks you to upgrade, means you didn’t upgrade before.

You can DM me your address or paste it here so I can double check.

1 Like

It didnt help and my wallet requires uprade to EVM, but the problem is that i have upgradet it already


Why don’t you use the 0x address? Since you have already upgrade it.

Use f(x)Core, not f(x)Core Classic.

Im using the 0x address that my wallet asks me to uprade. I have upgraded it, but it still asks me to upgrade it. Yesterday i upgraded second 0x address. I try to use fx-swap with that.

Hmm… May I ask what’s the address? Does it says ‘Migrate’ on the StarScan explorer?

I check it when im back home. I keep my wallet safe in my old phone.

0x66B43A987f6E095642F768403683dEA6DdE3cD94

0xb2Aa3d70dD46388FE4F7Fe418fF07FA1C3Dc5D92

Here are my 2 EVM compatible addresses. I tested 2nd address with fx-swap and it doesnt work. Same problem. Why it worked only once?


Now i cant even try to upgrade my wallet, but there is that notice that i should upgrade. I have some bugs in my wallet i quess.

I have the same message for my other addresses on fx classic. I’ve learnt to ignore it unless I really need to use it.

I know what you mean by the in app swap via the fx-swap.io. Yes I can confirm it does not do anything when I approve it.

I use the laptop, or my brothers smartphone to access FXSwap first, then scan it scan with my phone - this method works.

Further note, I’ve only managed to swap once with my own phone and fxwallet.

By the way I am using the latest version of the wallet and android 13.

I didn’t report thinking this was a wide spread known issue that is pending an update.

1 Like

Ignore the notice, it’s there for your other classic address.


Okay, let’s troubleshoot step by step.

  • Can you take a screenshot of your phone when you scan the FXSwap QR Code with your f(x)Wallet?
  • What screen do you get when you scan the QR Code on your phone?

You should be getting this screen. Choose → f(x)Core
image

Remember to click f(x)Core!

Hmm wait, I think I know what’s the problem. According to your picture, you didn’t add the other blockchain.

  • You only have f(x)Core Classic network listed so the system cant detect the others.
  • After you’ve upgraded, you can hide f(x)Core Classic because you won’t be using it any longer.

Try adding f(x)Core so the system can detect your EVM wallet.

Add f(x)Core and click ‘Save’.

1 Like

Fx-swap works now, when i use it in other phone than my wallet. It doesnt work in the same phone where my wallet is, it worked only once.

I hide the fx core classic address now and i have 3 fxcore addresses. Still the message shows that i need to upgrade, but i dont care about it anymore. I thought that it has something to do with the fx-swap problem, but it didnt.

Thank you very much for your help :blush:


No need for upgrade, but this is still here.

Same.

Thanks @SCENE

My classic address was hidden from a while back.

It won’t allow the swaps on the same phone. I think Indra mentioned if we wanted the old style quick swap on the wallet, therefore I was under the impression this will be released soon with this current bug addressed as priority.

Ive tried various trouble shootings in the past, i was unable to solve it.

1 Like