FXSwap : WalletConnect only showing MarginX address

Seen at least since OCT/31 1000 GMT+1 using F(x)Wallet v2.2 and current FXSwap.

When “Connecting to a wallet” using WalletConnect, F(x)Wallet only show the MarginX network address which, if selected on the mobile app, returns the following message: " Wrong Network ##### Please connect to the approprate Function X network. "

It makes FXSwap unusable at the moment…


1 Like

I was just in here to explain the same bug. I can confirm this as well. (android 13 user).

I had another message where it prompted on the fx wallet to connect via a Web browser. I tried it and it recognised the laptop I was using. It was weird, trying to replicate it again but not happening again.

And to add to this, it did fail on this prompt Web browser view from my phone.

Just tried Clearing the fx wallets cache, didn’t help still showing marginx.

Will try connecting to marginx and disconnect it from it, to see if anything changes. I will report if I can thereafter successfully swap.

I think it’s a problem coming from the website code or FxWallet, replacing the chain id ith MarginX chain id… Don’t waste your time, @Superbit123

Hi both, we are checking this problem and will fix it asap.

1 Like

Hi @FrenchXCore and @Superbit123 ,

Thanks both for the feedback, I have already checked, it’s a bug on the FXWallet v2.2 affecting only the android users. The team is already working on getting it fixed! :slight_smile:

1 Like

Updated to 2.2.1, fixed

1 Like

Can we get the fix done on iOS…. I’m still getting the same error as others have and cannot connect to a wallet.
App Store only shows Xwallet v2.2, not 2.2.1. I’m guessing the fix is just for android???

Hmm, I’m using multiple iOS phones and have no issue connecting on different versions. All of them are updated to v2.2.

May I know which version of the iPhone you are using?

iPhone 7+. With iOS version 15.6.1

Noted, will pass it forward.

Thank you.

I have already forwarded it.

But try clearing your website cache, see if this works.

  • Settings
  • Clear Browsing Data
  • Select → “Cookies and other site data” and “Cached images and files”
  • Clear Data

Thanks for your suggestions, I gave it a try and it worked somewhat.
I was able to connect to a wallet but now I’m getting a network error. I can’t see how I can change the network.
How do we change it?

May I know which wallet you are using to connect?

  • Does it have f(x)Core network?

Sure, I was trying Trust, MetaMask and Ledger but now that you say it must have the f(x) core network… I see the issue.
How do I then get it to connect to the Xwallet?

Currently, the recommended wallets are:

  • f(x)Wallet
  • MetaMask

Both of this wallets support f(x)Core network which should solve your issue.


To add f(x)Core Network on MetaMask:

  1. Go to https://chainlist.org/
  2. Search for ‘FX’
  3. Add f(x)Core to MetaMask



If you are using f(x)Wallet, just use WalletConnect and choose your f(x)Core address to connect.

  1. Click ‘WalletConnect’ and a QR Code will appear
  2. Scan the QR Code using f(x)Wallet Scan (Middle Button)
  3. Choose the f(x)Core address you want to connect
  4. All done.

Note: This is f(x)Wallet, not X Wallet.

X Wallet is a custodian wallet made by PundiXLabs.
f(x)Wallet is a non-custodian wallet.

Awesome, thanks for so much information.
My apologies, I meant to say f(x) wallet not Xwallet.
I’ve actually been trying to intuitively connect the f(x) wallet but didn’t know how to get to it.
With these instructions I think it will be great,I’ll let you know how it goes… once again thanks for your help.


No worries, if you need help again, just ping me. :blush: