Next f(x)Wallet upgrade - v3.7.3

The next scheduled upgrade for f(x)Wallet, for v3.7.3, is tentatively set for 8th March 2024.

The upgrade will fix the issue of NFT image not loading in Gallery and the bug of NFT selection placement mismatch that some users have reported.



the images in the BSC network came back for me, most on the Fx core are not though, the only one i see there is one from Daoverse, another one I have on an FX core wallet; is there twice without the image.


Not sure what you mean. Can you share screenshots of the issue you’re facing?

I went to get the screen shot and the double up issue seems to have resolved it’s self. there is no images for the fox NFT’s

After the update. I couldn’t send out anymore. I get this message. Anyone any clue? I have more than enough eth as gasfee.



Thank you raising this to our attention. I will feedback to the f(x)Wallet team.


Thanks a lot :pray:t3:

1 Like

Any updates? I really need my some of my coins!

@FrankiePhan ,
If you’re really in a hurry, you can use any other “clean” ERC20 wallet using your private key (like online Metamask extension for exemple).

100% understand your view, but using my private keys in a workaround is a no go for me. Hope the F(x) wallet team can respond asap.

Fun part.
Others then eth I can transfer. For example when I send BNB. For suddenly I could transfer my ata (ethcoin). But it looks like a one time transfer. As the 2nd time I tried to send another ethcoin, it was not working again.

There was an update on PundiX (and maybe FX) going on, due to the eth dencun upgrade.
Maybe it’s working again now…

Nope, still not working. But if I send another (not eth) coin first. Then I can do a 1time ethcoin transfer.

Hi @FrankiePhan

Can you share the failed transaction hash?

If you’re not comfortable sharing it here, please DM me on Telegram: @tehkosongpeng

I’ll have the f(x)Wallet team look into it.

Sorry for the trouble!

There is no transaction hash. The difference is between other coins and eth coins. For example if I use FX on eth and try to send the gasfee won’t calculte and when I send it on FXchain it calculates automatically.

The first one is on eth end the 2nd on fxchain

To be clear, this happens with all ethcoins. The gasfee wont appear. But as in my previous message. If I send out another coin, different from eth. Then I can send a eth coin 1 time and then the problem occurs again

Oh, this error. I think the team is aware of this because I forwarded it to the team a few weeks ago.

They might still be fixing it.

Try connecting it to the bridge browser, see if it works for you.

1 Like

Can you explain me more about the bridge browser?

Sure, no worries!

  1. Head over to f(x)Bridge on the browser
  2. Connect your f(x)Wallet
  3. Choose your receiving and sending chain
  4. Click “Transfer” and a prompt will appear in your f(x)Wallet for approval
  5. Boom shakalaka, all done.