Unable to withdraw reward

unable to withdraw fx staking reward, just loading…

Which staking are you referring to? Do you mean staking as in delegation?

yes FX delegation.

After you select ‘Undelegate’ and sign the transaction, there will be a 21-day unbonding period before you get your FX coins back for the prevention of manipulation purposes.

the process is not finished. the message “unable connect right now”.

I think he just wants to claim rewards, not to undelegate.
@nomo0808 , can you add one or two screenshots ?

1 Like

Ah! I missed the word ‘reward’, ops! :rofl:

1 Like

claim rewards, undelegate, change delegation all the same.

May I ask what version of your f(x) wallet you’re using and what phone you’re using?

Latest version: v2.3.2

please try to set the translation to english and try again

not yet successful. I undelegate because the Rock validator is not active, the description can’t connect, error code 10007

anyone experiencing the same thing?

Can you post pictures or videos of what you’re seeing please ?


Can you change your language to english and retry ?
Do you have enough FX to pay for the transaction fee ?
Can you give me your FX adress ?
Dis you recently update FxWallet to 2.3 ?

1 Like

-I guess language has no effect
-There is a balance of fx core 9, and fx classic 100, usually the fee is not up to 1 fx
-Wallet is the latest version

Hi @nomo0808 !

I guess there’s absolutely nothing preventing you from undelegating as I could see !
I don’t know if you tried changing the language in the app to English, but you should give it a try.
I can see your account still has 569 $FX delegated to ABI, 448 $FX to Rock, 448 $FX to Alif… (and nothing to us :slight_smile: ).
Beside that, I would strongly suggest you to:

  1. make sure you have your seedphrase backed up,
  2. uninstall the app,
  3. reinstall the app,
  4. retry…

If it still doesn’t work, contact the team…


I’ll switch from rock to you, if it works.

I already have a backup wallet on another phone, but it still doesn’t work.

backup wallet in english, but the problem is the same. no problem with previous version, have done some delegation switching.