F(x) Core validator node setup on f(x)Core Testnet

will this be for Codeless nodes as well, like we did in test net 1, 2 & 3 Zac

1 Like

Hi everyone, a new version of f(x)wallet has been launched. this will allow a configuration of f(x)core testnet.

1 Like

Additionally, we have just made some amends to our code base. we have added more details to the --help flag.

inside the fx-core dir, run:

git pull

and then:

make install

I hope so. @zaccheah any announcement to shift delegator to validator or do we need to undelegate our fx to get Validator?

apologies i missed this question.

if you are talking about how long it takes to get jailed after committing an offence, then it depends on the offence.
if it is a downtime issue and you tried to unjail it, then it should be within the block or once you have synced up.

by the way what is your validator address and moniker?

hi everyone, we will be updating the f(x)core code and validator logic at block height 1788888:
the update is that we will create be adding tron and polygon cross chain functions.

so you will need to restart your validators with the new logic and resync the blocks.

you will need to re git-clone the repo and you cannot just git pull it because we have modified the history of the code

1 Like

Im waiting for the codeless node. I want run via team server. im not a tech guy. :pensive:


just a taste of governance and decentralized marketing and a little bit of a social experiment. just a show of hands for the validators in this group and or anyone who wants to HAVE FREE TESTNET FX, could you give me your validator address and token holder address? im sending over some test tokens for yall to spread the love and spread the news about the latest proposals on testnet ive made that might soon become a reality

Thank you Richard, I think I’ve received already some today. I’ll resync the node next week.

Hi @Richard !

Fx token holder address : fx16rwkrl7qtqegeu73quyfln9q980a9ggvucct3w
TestNet FX node address: fxvaloper1nm0ryqn4atn9yvx3w44q0gfrdn4jgpp2saay7j


sent! happy using!

enjoy doing some testing with the testnet FX ive sent to you and let me know if you run into any issues with your node!

Hi Richard !!

It seems it worked perfectly, even though I had to unjail my validator again this morning.
I noted there was a small typo. When you submit a new vote, an item shows up on the bottom of the web page proposing to refresh that says “one new proposal” instead of “new vote”.


Hi @Richard !
For now, testnode still up and active. I’ll keep you updated.
I’ll probably update it to the new version next thursday.
As far as I can see, its vote power is still very close to 0, because most other nodes are close to millions of testFX being delegated to them. We should be able to tell within 2-3 days if it’s working better or not with more $testFX. But if that’s not the case, WE might either need you to undelegate 95% of other nodes $testFX or to send us much more… :wink:

Hello @everyone

i get error message such as the following
Error: error during handshake: error on replay: wrong Block.Header.AppHash. Expected 33BB8578B19087F7A57FAD7DC19B10630C24B25D532389DEBF42E296AFC7818D, got A90966236C1BFC19D62D5A2ACAAFDDAAB4C92D1762552BA63AC923676FD70B15

should i re-download snapshot or can fxcore reindex ?

Thank you

are you trying to do the snapshot sync?

the file might be corrupted. could you try to re-download the snapshot file and try again? if it doesnt work, ping me here again

@ClaudioxBarros i have added a recovery section for the validators, but i think youve already reinstalled fxcore so i think im a little too late?:slight_smile: but you can always reinstall and try again :slight_smile:

no, i aren’t

i updated from fxcored and re-clone souce core fxcore but after i try to restart fxcored testnet again that i get error message such as above

if i try to download snapshot that should i delete from directory of ~/.fxcore/data/ ?

Thank you

Yep, already reinstalled, almost sync. This test proposals are already in the end.
Would be better to make new ones for tests

@Richard ,
Not updated yet, but node’s jailed again (fxvaloper1nm0ryqn4atn9yvx3w44q0gfrdn4jgpp2saay7j)