F(x) Core validator node setup on f(x)Core Testnet

hi @dlin you have upgraded your code , it seems. You just have to wait til tommorrow, Tuesday (24 May), for the evm(new update) to get initiated , then your node will starting syncing the new blocks.

could you check your fxcored version and network?

The command fxcored version should return you :

hi all, for those who have validators setup on testnet(dhobyghaut).
There are still four that have not recovered and have started missing blocks after the evm upgrade.

:bar_chart: EA :robot: 31337 :chart_with_upwards_trend: Function X StarScan
Nammy Function X StarScan
„Unknown ” Function X StarScan
Alif-TestNet Function X StarScan

Kindly check and do reach out here if there’s any technical difficulties.


Sorry for the late response. It seems that our validator is jailed like you said. I tried to do the update process but it resulted in no actual update being done.

We had done the first EVM update. Missed second, and now when we went to do third it was not working.

So now we’re working on recovering the testnet node. Lets see how it goes.

EA and Nammy validators have been upgraded now and they’re up and running.

I’ve reported couple of bugs at GitHub with few issues which I’ve discovered.


Anyone know what the Algo used for the keys was back in the day? default is now eth_secp256k1

I even tried secp256k1…

anyone know?


fxcored keys add <fx_key_name> --algo secp256k1 --coin-type 118

yeah that worked with ofcourse --recover in the mix.

Alright !!! For everyone who needs to upgrade its TESTNET FxCore binaries over Linux AMD64, assuming your current user is Linux superuser (don’t type in the row numbers) :
→ Rows 01-02 install latest GoLang version 1.18.3) and row 03 allows you to check Go v1.18.3’s correctly running
→ Rows 04-11 update fxcore to latest v2.0.x testnet version
→ Row 12 should show testnet/v2.0.x-b0f3eaee6192734caf46d24c7c69ba07f6a6103b
→ Row 13 runs the service.

  1. wget https://go.dev/dl/go1.18.3.linux-amd64.tar.gz
  2. rm -rf /usr/local/go && tar -C /usr/local -xzf go1.18.3.linux-amd64.tar.gz
  3. go version
  4. cd ~/fx-core
  5. git pull
  6. git checkout testnet/v2.0.x
  7. make go.sum
  8. make install-testnet
  9. wget https://raw.githubusercontent.com/FunctionX/fx-core/testnet/v2.0.x/public/testnet/genesis.json -O ~/.fxcore/config/genesis.json
  10. wget https://raw.githubusercontent.com/FunctionX/fx-core/testnet/v2.0.x/public/testnet/config.toml -O ~/.fxcore/config/config.toml
  11. wget https://raw.githubusercontent.com/FunctionX/fx-core/testnet/v2.0.x/public/testnet//app.toml -O ~/.fxcore/config/app.toml
  12. fxcored version
  13. systemctl start fxcored

Waiting for Testnet explorer online to match the current new version… :wink:


How did the Testnet upgrade experience go? Hope it went well for our validator friends :slight_smile:

Hopefully, @Richard wasn’t far away.
A bit more instructions for upgrade would have been welcome.
But it went fine, and the New version is woooow !!!

all fine here :+1:

Hi guys,

I’m checking the account addresses and found they are totally different.
I’m following the steps to set up a validator here Setting Up a Validator for f(x)Core - Function X Docs

I’m doing this step to ensure the account address, but it shows me totally 2 different addresses

$ fxcored keys parse $(cat ~/.fxcore/config/priv_validator_key.json| jq -r '.address')
acc_address: fx14p8ws6wuxqhtt2u6kdcfyyvqqhsns7vpr5wz6m
base64_address: qE7oadwwLrWrmrNwkhGABeE4eYE=
eip55_address: 0xA84ee869DC302Eb5ab9aB37092118005E1387981
hex_address: a84ee869dc302eb5ab9ab37092118005e1387981
val_address: fxvaloper14p8ws6wuxqhtt2u6kdcfyyvqqhsns7vpt9naym
$ fxcored tendermint show-address

Then I check my token holding account

$ fxcored keys list
Enter keyring passphrase:
- name: xxxx_xxxx
  type: local
  eip55_address: 0x0Cfe94f152DDF7133cC908c1faE3cf02F31927a7
  address: fx1pnlffu2jmhm3x0xfprql4c70qte3jfa8klq7p8
  pubkey: '{"@type":"/ethermint.crypto.v1.ethsecp256k1.PubKey","key":"xxxxxxxxx"}'
  algo: eth_secp256k1

Can someone help me explain what is different between 3 different account addresses there and do we need to make sure all of them are the same address before running the vadilator?


Hi @john !

From what I understood, in the latest version of fxcored app, different type of keys are being used.
You have two different key algorithms being used : the cosmos and ethermint.
Moreover, in Cosmos, you have different kind of addresses being used for different purposes : fx1… (account address), fxvaloper1… (validator address), fxvalcons1… (validator consensus address) and fxvalconspub1… (validator consensus public address).

The reason why your eip55 address is different in the two cases is probably because they use a different algorithm. However, it is clear for now that when you depley a validator, you should not migrate your address to ethermint type (at least, that’s what was advised).

Hope this helps.


1 Like

Thanks @FrenchXCore

Hi everyone, I’m currently at the step on setting up Full Node with Binaries, when I try to download snapshot by running the command wget -c https://fx-testnet.s3.amazonaws.com/fxcore-snapshot-testnet-2022-05-23.tar.gz, I get the error

HTTP request sent, awaiting response... 403 Forbidden
2022-06-27 02:53:22 ERROR 403: Forbidden.

Are the team updating the snapshot or is it my problem here? I’m using my local Windows PC to connect to the AWS Ubuntu Instance.
Really appreciate if anyone could help me. Thanks.

Hi !

I’m assuming you’re setting up a testnet full node.
Snapshot is published every monday usually.
Try this : wget -c wget -c https://fx-testnet.s3.amazonaws.com/fxcore-snapshot-testnet-2022-06-27.tar.gz
If it doesn’t work yet, use this : wget -c https://fx-testnet.s3.amazonaws.com/fxcore-snapshot-testnet-2022-06-20.tar.gz


Thanks, the second link works for me.

1 Like

Hi, to set up a sentry node for validator according to this article Sentry Nodes, is it the same process as setting up a full node? and edit property in config.toml of both sentry node and validator? Thanks.